Web Browser Compatibility

 

We currently support versions of Google Chrome 13+ (highly recommended), Mozilla Foxfire 3.6+Apple Safari 6+Internet Explorer 10+.   Even if you're using one of these three, make sure each is completely up to date, as out of date web browsers can cause issues.

If you're on an older version of OSX (10.6 or earlier), Safari will say it's up to date, but it's really prevented from updating past a certain point, and without some core components, including Adobe Flash, which is what the some of the "buttons" in the application work off of. We recommend switching to either Google Chrome or Firefox, as this will remedy the issue. 

 

Was this article helpful?
1 out of 1 found this helpful
Have more questions? Submit a request

Comments